Dienstag, 5 Jan 2016

[CFT]Centos 6.7 userland update.

Hi,

First post in 2016 🙂 this is a Call For Testing (CFT) of our new Centos 6.7 userland update.

This update includes a lot of fixes, including Skype which has been broken for a few months now. We’d like your feedback about performance and experience of general usage like Flash, or any games that require Linux Emulation. This update comes of course for with 32bit and 64bit variants.

To test the 64-bit version [1], add the following to /etc/make.conf:

OVERRIDE_LINUX_BASE_PORT=c6_64
OVERRIDE_LINUX_NONBASE_PORTS=c6_64

[1] NOTE: Skype will *NOT* work with the 64-bit version, as it is a 32-bit binary

There are two ways to apply the update

1) If your ports tree is a portsnap checkout, ensure its up to date and run
following commands.


cd /path/to/your/ports tree
fetch https://reviews.freebsd.org/file/data/laadv2druzpxvwtc4dlq/PHID-FILE-4k5m7x4jyhdh3jysgwzl/D3428.diff
patch < D3428.diff
find . -name '*.orig' -delete

2) If your ports tree is a svn checkout, ensure its up to date, and you have devel/php5-arcanist installed and a account here (For more infos about review please click here. run
following commands.


cd /path/to/your/ports tree
arc patch D3428

It will update all related ports.

That’s it, you can run a normal portmaster or portupgrade upgrade upgrade, or just install any Linux port you like :-).

There is a known plist issue with x11-toolkits/linux-c6-qt47-x11, which
has no impact for testing but we are working on it.

Thanks for your time and testing all your feedback is welcome 🙂

Have fun 🙂


5 Responses to “[CFT]Centos 6.7 userland update.”

  1. Oleg Sidorkin Says:

    running FreeBSD 10.2-STABLE #0 r293616 with linux,ko and linux64.ko:

    1) /compat/linux/bash segfaults (while e.g. sort works fine)
    2) linux flashplugin produces messages „/lib/ld-linux.so.2 not found“

  2. miwi Says:

    Thanks I’ll look why.

  3. miwi Says:

    Okay it turn out that dump is happened while mixing 32bit with 64bit. It should be fixed with a fresh HEAD.

    [17:30][miwi@miwibox] $ /compat/linux/bin/bash (~)
    bash-4.1$

  4. Oleg Sidorkin Says:

    … and now stable/10 is ok too

  5. Oleg Sidorkin Says:

    Seems that

    /usr/lib/libpulse-mainloop-glib.so.0
    /usr/lib/libpulse-mainloop-glib.so.0.0.4

    should be removed from
    audio/linux-c6-pulseaudio-libs/pkg-plist.x86_64
    since there are no such files in
    pulseaudio-libs-0.9.21-21.el6.x86_64.rpm
    and they are present in
    pulseaudio-libs-glib2-0.9.21-21.el6.x86_64.rpm

    so it seems that audio/linux-c6-pulseaudio-libs-glib2 should be updated also,

Leave a Reply